PDA

View Full Version : indesign text justification


FlipSide
05-26-2008, 04:47 AM
hi guys,

I've used "justify with last line aligned left" in the past on cs2 and it worked like a dream, but i've just tried it with cs3 and it doesn't seem to work at all (vista x64). anyone else have this problem? I'm hoping its a setting somewhere. anyone got any ideas?

"justify all lines" works as expected

I've even done the old trick of pasting the formated text into a txt file and then paste that into indesign.

Howard Allen
05-26-2008, 11:11 AM
I dunno. It works fine on OSX. What exactly do you mean when you say "it doesn't work at all"? Do you mean you click on the justify button and nothing happens? Does it do something else?

Is your paragraph selected when you try to justify it? (If you had no paragraph selected, justification wouldn't do anything when you clicked it.) Does your paragraph have a style applied to it? (Though justifying an already styled paragraph should create an override, and justify it anyway.)

What happens if you create a new InDesign document from scratch and type a few lines of text into a text frame? Does it work there? Or is the problem only within existing documents that have paragraph styles applied?

Michael Rowley
05-26-2008, 11:31 AM
I've used "justify with last line aligned left" in the past on cs2 and it worked like a dream, but i've just tried it with cs3 and it doesn't seem to work at all

I get (in Vista 32) this on looking at Help in CS3, but I have only just upgraded, so I have not tried it yet.


Justify all lines
: Shift+Ctrl+F (all lines) or J (all but last line)

FlipSide
05-26-2008, 04:38 PM
Hi guys,

yeap, did all of the above before i posted. I used the same text that was copied using notepad (removing any formating). lol yes i used the button to justify it in the paragraph pallete (homer simpsons famous quote comes to mind for that one). checked all options for both text frames, both on the paragraph fly-out and the right-click "text frame options". both were identical in every way, other justification options worked but the text just would not "justify with last line aligned left" on the first text frame.

NB: i created the second text frame after a restart of the pc. the new text frame works fine, but the "old" one is still with the same weird problem. argh!!

anyway, I had to create 120 new text frames any copy/paste the existing text and it worked fine. go figure. I was hoping it was a silly setting somewhere that was stopping it but no such luck.

while we're on the subject, i have the preferences > when pasting text.... > text only radio button selected. how do you guys clear any formating (if needed) from text before u paste it into ID?

thanks for your help guys.

FlipSide
05-26-2008, 06:58 PM
I found this great little tool earlier via good old google (eliminates the copy/paste to notepad step)

PureText (http://www.stevemiller.net/puretext/)

Howard Allen
05-26-2008, 09:04 PM
the new text frame works fine, but the "old" one is still with the same weird problem. argh!!

anyway, I had to create 120 new text frames any copy/paste the existing text and it worked fine. go figure. I was hoping it was a silly setting somewhere that was stopping it but no such luck.

Sounds like a corrupt file. It happens, occasionally. If it becomes a recurring problem, you might try and reset the application preferences, however that's done in Windows. In OSX it's done by restarting the application while holding down a key combination.

while we're on the subject, i have the preferences > when pasting text.... > text only radio button selected. how do you guys clear any formating (if needed) from text before u paste it into ID?

Depends where/what I'm pasting it from. Typically, I don't paste text into InDesign, except from another InDesign document. Rather, I use the Place command, making sure the "Show Import Options" box is checked, and "Remove styles and formatting from text and tables" button is selected. This will clear all formatting from the placed text.

The main benefit of placing un-styled/formatted text is just to keep other people's Word style sheets from being dumped in among my ID style sheets, which I really hate(!). Otherwise, it's simple enough to place the formatted text, then select and restyle it with my own style sheets, or just select the formatted text and apply the "Basic Paragraph" style (holding down shift-alt--for you Windows folk--or shift-option on Mac, to remove any overrides) if for whatever reason you want the text unformatted in ID.

Cheers,

FlipSide
05-27-2008, 04:17 AM
I use place for a lot of lengthy brochures etc...so handy! this particular job is a mix of different sources (emails, word docs, old pdfs)...so pasting was the easier to handle option as things had to be juggled constantly (don't you just hate those jobs!!!)

you might try and reset the application preferences, however that's done in Windows. In OSX it's done by restarting the application while holding down a key combination.
hold down shift at program startup (for other windows users)

holding down shift-alt--for you Windows folk--or shift-option on Mac, to remove any overrides
oooh! thanks for that one! :)

Michael Rowley
05-27-2008, 11:54 AM
Over the years I have had occasions when a particular paragraph has refused to behave as it should, either because of corruption or through hitting inadvertently some combination of keys that were a shortcut to some unrecognized function. In the long run I have found it best to rescue the affected text (in another program), delete the paragraph, and then recreate it afresh. That should work with faulty frames too. Of course, you might have tried that already!

FlipSide
05-27-2008, 04:47 PM
Hi Michael, thanks for your input, thats exactly what I had to end up doing to make it work (post #4)....oh t'was driving me nuts. had a similar problem before in frustrater - a selection problem - and it ended up i hit a preference shortcut inadvertently (note to self...stop fisting the keyboard, LOL). with the text frame in indesign, seems it just got corrupt somehow as Howard mentioned above, just a single page amongst many - page 44. dunno why as I generally create new files from scratch (as opposed to standard business cards) and had no crashes of any sort. anyways thanks as usual for the feedback - its ALWAYS invaluable!